Notes submission failures to Athena and Cerner

Incident Report for Suki Platform

Resolved

The incident affecting users of Athena and Cerner has been fully resolved. We apologize for any inconvenience caused and appreciate your patience during this time.
Posted Oct 20, 2025 - 15:38 PDT

Update

We are continuing to actively monitor the recovery of AWS and affected EMRs impacting Suki users. If you're experiencing any issues, please contact our support team.
Posted Oct 20, 2025 - 13:02 PDT

Monitoring

Amazon Web Services experiencing and outage which is causing downstream issues with multiple EMRs and other services for Suki users.
Posted Oct 20, 2025 - 08:05 PDT
This incident affected: Platform APIs, Mobile SDK, and Web SDK.